Certbot-auto - corriger l'erreur ImportError: No module named _ssl

Certbot-auto est un utilitaire qui permet d'installer les certificats SSL de Let's Encrypt sur votre serveur Apache2. Lors d'une mise à jour de distribution de Linux (par exemple de Debian 7 à Debian 8), l'utilitaire certbot-auto peut vous retourner un message d'erreur ressemblant à ceci :

Upgrading certbot-auto 0.21.0 to 0.24.0...
Replacing certbot-auto...
Error: couldn't get currently installed version for /opt/eff.org/certbot/venv/bin/letsencrypt:
Traceback (most recent call last):
  File "/opt/eff.org/certbot/venv/bin/letsencrypt", line 7, in <module>
    from certbot.main import main
  File "/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/certbot/main.py", line 10, in <module>
    import josepy as jose
  File "/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/josepy/__init__.py", line 41, in <module>
    from josepy.interfaces import JSONDeSerializable
  File "/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/josepy/interfaces.py", line 8, in <module>
    from josepy import errors, util
  File "/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/josepy/util.py", line 4, in <module>
    import OpenSSL
  File "/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/OpenSSL/__init__.py", line 8, in <module>
    from OpenSSL import rand, crypto, SSL
  File "/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/OpenSSL/rand.py", line 12, in <module>
    from OpenSSL._util import (
  File "/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/OpenSSL/_util.py", line 6, in <module>
    from cryptography.hazmat.bindings.openssl.binding import Binding
  File "/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/cryptography/hazmat/bindings/openssl/binding.py", line 156, in <module>
    Binding.init_static_locks()
  File "/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/cryptography/hazmat/bindings/openssl/binding.py", line 140, in init_static_locks
    __import__("_ssl")
ImportError: No module named _ssl

Comment corriger cette erreur

Il vous suffit de taper cette commande dans votre terminal en mode administrateur (utilisateur 'root'):

rm -rf /opt/eff.org

et de lancer de nouveau votre utilitaire certbot.

Par exemple :

certbot-auto

Notes de version

  • [14/05/2018] : Création de l'article

Auteurs et sources