Corriger l'erreur "Le pilote pour la méthode /usr/lib/apt/methods/https n'a pu être trouvé"

Lors de l'exécution de la ligne de commande apt-get update il apparaît parfois le message d'erreur suivant :

E: Le pilote pour la méthode /usr/lib/apt/methods/https n'a pu être trouvé.
N: Is the package apt-transport-https installed?

Corriger l'erreur

Pour corriger cette erreur, il faut installer le paquet apt-transport-https avec la ligne de commande suivante :

apt install apt-transport-https

ou

aptitude install apt-transport-https

Avertissement

Le système d'installation peut dans certains cas vous afficher l'avertissement suivant :

Les NOUVEAUX paquets suivants vont être installés :
  apt-transport-https

0 paquets mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 138 ko d'archives. Après dépaquetage, 195 ko seront utilisés.
ATTENTION : des versions non certifiées des paquets suivants vont
être installées.

Des paquets non certifiés peuvent compromettre la sécurité de votre
système. Vous ne devriez les installer que si vous êtes certain
que c'est bien votre intention.

  apt-transport-https

Voulez-vous ignorer cet avertissement et continuer quand même ?
Pour continuer, entrer « Oui ». Pour interrompre l'installation, entrer « Non » : 

Vous pouvez valider l'installation en entrant "oui".

Notes de version

  • [02/05/2018] : Création de l'article

Auteurs et sources